Back to overview
Degraded

Delays to some outgoing SMS

Mar 26 at 05:08am PDT
Affected services
TeamSense app

Resolved
Mar 26 at 07:37am PDT

Our messaging provider has confirmed this issue was resolved at approximately 9 AM Eastern Time, though they are continuing to monitor message delivery. Queued messages will continue to deliver throughout today. Thank you all for your patience!

Created
Mar 26 at 05:08am PDT

Some of our users are experiencing delays in SMS sent from TeamSense to their mobile device due to a service disruption from one of our messaging providers. We are monitoring updates from our messaging provider and will provide updates here. Please reach out to our team with any questions at support@teamsense.com.